Google under fire for refusing to fix a security bug in pre-KitKat Android versions

While Google’s discontinued support for plenty of things in the past under the excuse of “spring cleaning”—see Google Reader—this time, it’s facing particular criticism for the latest discontinued item. Google’s announced that it’ll no longer perform bugfixes in pre-KitKat versions of Android for a piece of software called WebView. Said software is used to display web pages; while present in KitKat and Lollipop, it’s been replaced by a newer/different version of the software than the one used by pre-KitKat Android versions. Google’s stated that while it’ll no longer fix any WebView bugs itself, it will allow original equipment manufacturers, or OEMs (Samsung, LG, etc.), to fix the bugs themselves.

Although companies don’t support older versions of operating systems forever, there’s several issues with Google cutting off security support for this component. For starters, 60% of Android devices operating are still running pre-KitKat versions of the OS. There’s also how glacial OEMs are at offering upgrades or patches, if they bother doing so at all—they’d rather you bought a newer phone than invest much in support. Finally, there’s a lot of headlines about Google’s actions casting a negative light on this. More so with this coming days after Google was criticized by Microsoft for publicizing a bug in Windows several days before they could release a patch.

While it remains to be seen whether anything disastrous will happen from this, the publicity and headlines aren’t casting Google in a favorable light. Although Android’s position as the dominant mobile OS seems cemented by now, I could see a few people perceive Android as “not safe” or “lackluster” in terms of support, and opt instead to make their next phone an iPhone.

Leave a Reply

Your email address will not be published. Required fields are marked *